Jump to content

Finally building (and tearing down) the 77


aenigma
 Share

Recommended Posts

13 hours ago, aenigma said:

Axle. 
I meant mine was an axle too lol, so a much less expensive fix but more time consuming. So Saturday is out darn it. 

 

So did you shear the axle at the spindle?

Link to comment
Share on other sites

23 hours ago, Buccaneer said:

A real bummer Mo and feel your pain. I texted Lonnie last night hoping to hear great news and he said you broke, but I didn't know you guys were still at the track waiting for the truck when I sent the text. That sucks! Did it break/quit at launch?

 

On the C8 issues of being too low, don't they all have that front end raise to lift it up for bumps etc...? OR is that an option he didn't have? I can't believe GM would make it so it couldn't load on to a truck when broke on the road, but maybe they did. YIKES! Be aware for all the C8 owners out there.

If they roll them off a transporter I wouldn't think a rollback would be any steeper.  I doubt if local delivery to the dealers is through a double high trailer with those lifts that  eliminate the angle issue???

Link to comment
Share on other sites

14 hours ago, aenigma said:

Axle. 
I meant mine was an axle too lol, so a much less expensive fix but more time consuming. So Saturday is out darn it. 

 

Did Lonnie not tell you to not break an axle?   😉

Link to comment
Share on other sites

3 hours ago, JohnU said:

 

Did Lonnie not tell you to not break an axle?   😉


ha I guess it launched harder after the upgrades than we thought it would (which isn’t a sad issue at all). The axles were new.

Link to comment
Share on other sites

On 10/18/2020 at 8:20 PM, aenigma said:

Axle. 
I meant mine was an axle too lol, so a much less expensive fix but more time consuming. So Saturday is out darn it. 

Too bad it wasn't a trans cooler line like Julies. Car on the road next day and repair expense was less than $10 since I already had extra hose.

 

Link to comment
Share on other sites

2 hours ago, Extender32 said:

Too bad it wasn't a trans cooler line like Julies. Car on the road next day and repair expense was less than $10 since I already had extra hose.

 


no kidding! 
the spindles will be here tomorrow so I’m making race day on Saturday. Yea! 
Still way better than a transmission. I think they ended up $400 for both. 

AE7F069E-FE33-4626-8F09-0CC84FE319BB.jpeg

Link to comment
Share on other sites

14 hours ago, aenigma said:


no kidding! 
the spindles will be here tomorrow so I’m making race day on Saturday. Yea! 
Still way better than a transmission. I think they ended up $400 for both. 

AE7F069E-FE33-4626-8F09-0CC84FE319BB.jpeg

oh snap!

Link to comment
Share on other sites

19 hours ago, aenigma said:


no kidding! 
the spindles will be here tomorrow so I’m making race day on Saturday. Yea! 
Still way better than a transmission. I think they ended up $400 for both. 

AE7F069E-FE33-4626-8F09-0CC84FE319BB.jpeg

Too much power or driver error, or both.

Link to comment
Share on other sites

I'm willing to bet that it really has to do with the cheap azz Chinese junk steel. I bet Lonnie will agree.  Put some good old Made in USA steel in there and that C3 is gonna be a rocket at launch.  GL Mo! :thumbs

 

With this launch that broke it...It WILL be a beast to reckon with. Hell Yeah Mo, kick some azz Saturday. Those wheels are destined to get some AIR. :burnout

 

IMG_0252.jpg

  • Like 1
Link to comment
Share on other sites

If there's voting to be done, mine is for improper heat treating and/or failure to radius deburr the machining transition, considering what little I can see of the fracture in the photo.

Link to comment
Share on other sites

Now that it is all back together with Tom's spindles, it should work just fine. GL tomorrow at the races Mo! Give em hell.  :thumbs

Link to comment
Share on other sites

5 hours ago, Buccaneer said:

Now that it is all back together with Tom's spindles, it should work just fine. GL tomorrow at the races Mo! Give em hell.  :thumbs


thank you buccaneer! Lonnie worked his tail off all day yesterday installing toms. He’s awesome. It’s ready to go. 
 

hoxxoh, it’s aftermarket cheap metal. If you look within the spindle, it’s all twisted and bent throughout. That shouldn’t have happened with upgraded metal. Even stock metal wouldn’t have done that. 

Link to comment
Share on other sites

They were obviously made incorrectly.  Weaker than stock, my mistake. These should be much better. 
 

4B291B3E-D96A-4504-AB17-08A119A0E6B0.jpeg

Link to comment
Share on other sites

Getting there at 11.627. DA 4000

working on getting to 11.5 grrrr. I keep shifting too fast.  

 

 

 

 

57CC609A-A0BE-4445-919A-06A03B4D8F33.jpeg

  • Upvote 1
Link to comment
Share on other sites

  • 2 months later...

It finally hit under 11.5 tonight. Waited 5 1/2 hours for one run. Unfortunately it wasn’t me. I had a dirt bike accident last weekend so I can’t use both feet. Lonnie was happy to finally drag it. 
 

EC558DDA-130B-49DE-BD85-9176F35FF634.jpeg

6578BE40-8D1A-46E7-824D-62B9DCD2FEF7.jpeg

Link to comment
Share on other sites

Sorry about the dirt bike mishap! 

 

Sounds like operator error happening.  Cars runs fine, just tune up the long haired driver!  😉

Link to comment
Share on other sites

51 minutes ago, JohnU said:

Sorry about the dirt bike mishap! 

 

Sounds like operator error happening.  Cars runs fine, just tune up the long haired driver!  😉


Of course it is. Which is why I didn’t want him to drive it until last night since I couldn’t. He’s a great driver and I didn’t want to get crapped out knowing what I could do but haven’t yet. Surprisingly I was really happy he got what he did. He could’ve done better but wasn’t used to the shifting the way he set it up for me so he hit the rev limiter. His is different. I can’t wait to get back out there. 

Link to comment
Share on other sites

17 hours ago, aenigma said:

It finally hit under 11.5 tonight. Waited 5 1/2 hours for one run. Unfortunately it wasn’t me. I had a dirt bike accident last weekend so I can’t use both feet. Lonnie was happy to finally drag it. 
 

EC558DDA-130B-49DE-BD85-9176F35FF634.jpeg

6578BE40-8D1A-46E7-824D-62B9DCD2FEF7.jpeg

Oh HELL YEAH! Nice time and 60'. It WILL go faster for sure. I wish Lonnie would have text me last night that you were going, I wasn't doing anything and may have gone. SUCKS, that they had WAY too many people there and you had to wait forever. Ugh!

 

Link to comment
Share on other sites

  • 1 month later...

Oops - I either need to slow down or add more safety equipment. Teched to 11.5.  Drag nights are kind of back! 

 

77526386-C9C6-4A7A-8FA5-4270A3F2E3B4.jpeg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...